Problem
When starting a calibration in QAWeb Agent, I am prompted to restart the application as a local administrator.
When starting the calibration from the 'Status' window:
Or when starting the calibration from the 'Configuration' window:
Root cause
Because of the SteadyColor calibration and the additional features that come along with it in the Intuitive Workflow Tools Barco provides with the MXRT display controllers, we install an ICC profile after the calibration. The Windows operating system requires local administrator rights to install this ICC profile.
Affected displays
This only happens on displays which support the 'SteadyColor' calibration, currently the following models:
- MDMC-12133 (Coronis Uniti)
- MDNC-6121 (Nio 5MP Color)
Solution
If you open the application normally (double-click the application shortcut or double-click the QAWeb Agent systray icon), then it is not started with local administrator rights, even if you are a local administrator on the workstation. This is how recent versions of Windows protect the user from doing accidental harm to the system.
You need to right-click the application shortcut and choose 'Run as administrator' to actually start the application with elevated rights.
Exception
Because of how Windows is designed, the QAWeb background service which runs as a 'Local system account' does not require these elevated rights to do the calibration (or better: has by default these elevated rights). So any scheduled calibration or calibration which is started remotely from QAWeb Server will succeed without any manual intervention.